ubuntu-mechanize(ruby)環境構築

sudo apt install ruby

vagrant@pj-3:~/code/wdp_xml_rpc/wordPress_Post_executer/src$ ruby -v
ruby 2.5.1p57 (2018-03-29 revision 63029) [x86_64-linux-gnu]

参考サイトURL:
http://d.hatena.ne.jp/supermassiveblackhole/20110118/1295321109

gemはaptでインストールします.当然Rubyが必要になります.Ubuntu10.10には標準でRubyが入っていたと思いますが,ruby-devなども入れておいたほうが良いです.以下のコマンドを実行します.

参考URL:http://kouritool.com/what-linux/ubuntu%E3%81%ABrubymechanize%E3%82%92%E3%82%A4%E3%83%B3%E3%82%B9%E3%83%88%E3%83%BC%E3%83%AB%E3%81%99%E3%82%8B/

sudo apt-get install libxslt-dev libxml2-dev
sudo apt-get install ruby-dev
sudo gem install nokogiri
sudo gem install mechanize

スポンサーリンク

シェアする

  • このエントリーをはてなブックマークに追加

フォローする

スポンサーリンク